FreeBSD прекратило распространение портов через CVS и CVSupНачиная с 28 февраля 2013 года порты FreeBSD перестанут быть доступны через CVS, т.е. их нельзя будет зеркалировать или синхронизировать для поддержания в актуальном виде через такие инструменты как CVSup. Причиной прекращения поддержки CVS является переход к использованию Subversion для разработки и поддержания дерева портов, в то время как используемые средства экспорта SVN в CVS имеют ряд ограничений, приводящих к затруднениям при организации работы зеркал. Пользователям предлагается спланировать переход на portsnap или svn для обновления дерева портов. |
# uname -a FreeBSD web0.domain.ua 7.0-RELEASE FreeBSD 7.0-RELEASE #0: Sun Feb 24 10:35:36 UTC 2008 root [at] driscoll [dot] cse [dot] buffalo [dot] edu:/usr/obj/usr/src/sys/GENERIC amd64 |
# mkdir /etc/csup |
# cat /etc/csup/src-all *default host=cvsup3.ua.FreeBSD.org |
# cat /etc/csup/ports-all
*default host=cvsup3.ua.FreeBSD.org |
# cat /etc/csup/doc-all
*default host=cvsup2.ua.FreeBSD.org |
# cat /etc/csup/src-sys *default host=cvsup3.ua.FreeBSD.org |
# cat /etc/csup/src-all *default host=cvsup3.ua.FreeBSD.org |
25 2 * * * root /usr/bin/csup -g -L 2 /etc/csup/ports-all > /dev/null 2>&1 |
# csup -g -L 2 /etc/csup/src-all |
Если на экране видим следующий вывод
Connecting to cvsup3.ua.FreeBSD.org
Connected to 212.42.64.9
Server software version: SNAP_16_1h
Negotiating file attribute support
Exchanging collection information
Establishing multiplexed-mode data connection
Running
|
Shutting down connection to server
Finished successfully
|
# 1. `cd /usr/src' (or to the directory containing your source tree).
# 2. `make buildworld'
# 3. `make buildkernel KERNCONF=YOUR_KERNEL_HERE' (default is GENERIC).
# 4. `make installkernel KERNCONF=YOUR_KERNEL_HERE' (default is GENERIC).
# [steps 3. & 4. can be combined by using the "kernel" target]
# 5. `reboot' (in single user mode: boot -s from the loader prompt).
# 6. `mergemaster -p'
# 7. `make installworld'
# 8. `make delete-old'
# 9. `mergemaster' (you may wish to use -U or -ai).
# 10. `reboot'
# 11. `make delete-old-libs' (in case no 3rd party program uses them anymore)
|
# cd /usr/src/
# make -j4 buildworld
|
--------------------------------------------------------------
>>> World build completed on Sat Aug 8 03:48:39 EEST 2009
--------------------------------------------------------------
|
# cp /usr/src/sys/amd64/conf/GENERIC /usr/src/sys/amd64/conf/Web0 |
# ee /usr/src/sys/amd64/conf/Web0 |
# $FreeBSD: src/sys/amd64/conf/GENERIC,v 1.484.2.21 2009/07/15 08:32:19 ed Exp $
cpu HAMMER
ident Web0
options SCHED_ULE # ULE scheduler
options PREEMPTION # Enable kernel thread preemption
options INET # InterNETworking
options FFS # Berkeley Fast Filesystem
options SOFTUPDATES # Enable FFS soft updates support
options UFS_ACL # Support for access control lists
options UFS_DIRHASH # Improve performance on big directories
options UFS_GJOURNAL # Enable gjournal-based UFS journaling
options GEOM_PART_GPT # GUID Partition Tables.
options GEOM_LABEL # Provides labelization
options COMPAT_43TTY # BSD 4.3 TTY compat [KEEP THIS!]
options COMPAT_IA32 # Compatible with i386 binaries
options COMPAT_FREEBSD4 # Compatible with FreeBSD4
options COMPAT_FREEBSD5 # Compatible with FreeBSD5
options COMPAT_FREEBSD6 # Compatible with FreeBSD6
options KTRACE # ktrace(1) support
options STACK # stack(9) support
options SYSVSHM # SYSV-style shared memory
options SYSVMSG # SYSV-style message queues
options SYSVSEM # SYSV-style semaphores
options P1003_1B_SEMAPHORES # POSIX-style semaphores
options _KPOSIX_PRIORITY_SCHEDULING # POSIX P1003_1B real-time extensions
options KBD_INSTALL_CDEV # install a CDEV entry in /dev
options ADAPTIVE_GIANT # Giant mutex is adaptive.
options STOP_NMI # Stop CPUS using NMI instead of IPI
options AUDIT # Security event auditing
#options KDTRACE_FRAME # Ensure frames are compiled in
#options KDTRACE_HOOKS # Kernel DTrace hooks
# Make an SMP-capable kernel by default
options SMP # Symmetric MultiProcessor Kernel
# CPU frequency control
device cpufreq
# Bus support.
device acpi
device pci
# ATA and ATAPI devices
device ata
device atadisk # ATA disk drives
options ATA_STATIC_ID # Static device numbering
# atkbdc0 controls both the keyboard and the PS/2 mouse
device atkbdc # AT keyboard controller
device atkbd # AT keyboard
device kbdmux # keyboard multiplexer
device vga # VGA video card driver
device splash # Splash screen and screen saver support
# syscons is the default console driver, resembling an SCO console
device sc
# PCI Ethernet NICs that use the common MII bus controller code.
# NOTE: Be sure to keep the 'device miibus' line in order to use these NICs!
device miibus # MII bus support
device nfe # nVidia nForce MCP on-board Ethernet
device sk # SysKonnect SK-984x & SK-982x gigabit Ethernet
# Pseudo devices.
device loop # Network loopback
device random # Entropy device
device ether # Ethernet support
device pty # Pseudo-ttys (telnet etc)
device firmware # firmware assist module
device vlan # 802.1Q VLAN
# The `bpf' device enables the Berkeley Packet Filter.
# Be aware of the administrative consequences of enabling this!
# Note that 'bpf' is required for DHCP.
device bpf # Berkeley packet filter
# My options
options IPFIREWALL
options IPFIREWALL_VERBOSE
options IPFIREWALL_VERBOSE_LIMIT=100
options IPFIREWALL_DEFAULT_TO_ACCEPT
options IPFIREWALL_FORWARD
options DUMMYNET
options QUOTA
options ACCEPT_FILTER_HTTP
|
# make kernel KERNCONF=Web0 |
# shutdown -r now |
# shutdown -r now |
# /sbin/mount -u /
# /sbin/mount -a
# su
# mergemaster –p
|
# cd /usr/src
# make installworld
|
# mergemaster -cv |
# shutdown -r now
# cd /usr/src/
# make delete-old-libs
|
# uname -a FreeBSD web0.domain.ua 7.2-STABLE FreeBSD 7.2-STABLE #0: Sat Aug 8 04:58:58 EEST 2009 muff [at] web0 [dot] domain [dot] ua:/usr/obj/usr/src/sys/Web0 amd64 |
# csup -g -L 2 /etc/csup/ports-all |
Shutting down connection to server
Finished successfully
|
Последние комментарии
16 недель 2 дня назад
40 недель 4 дня назад
2 года 41 неделя назад
3 года 11 недель назад
3 года 34 недели назад
3 года 49 недель назад
3 года 49 недель назад
4 года 1 неделя назад
4 года 12 недель назад
4 года 16 недель назад